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Preface
Welcome to Logidraw, the drawing tool for process safety engineers. It lets you create
fault tree diagrams and event tree diagrams as part of a hazard analysis or safety case.

About this guide
This guide is designed to assist you in becoming quickly familiar with the capabilities
of Logidraw, its interface and how the program is used.

Who should read this guide
This guide is written for users of Logidraw to help you take full advantage of its
calculation tools. If you are new to this product, we recommend that you first read The
60 Second Guide to Logidraw :Fault Trees and The 60 Second Guide to Logidraw:
Event Trees.
The guide assumes you are familiar with the Windows operating system. If you are
new to Windows, you can find help, tutorials and support information by clicking
Start > Help and Support.

What is in this guide
The guide contains descriptions and step-by-step instructions for all the tasks involved
in using Logidraw.

How this guide is structured
The chapters are organised as follows:
1.

Introduction

Introduces the product, outlining the main
features.

2.

Getting started

Shows how to start Logidraw, introducing the
user interface for the application.

Part A – Fault Trees
3.

Logidraw Fault trees Quick
Tour

Tutorial for typical session using Logidraw to
draw a fault tree, emphasising the commonly
used features

4.

Fault tree basics

How to create, change and delete fault trees.

5.

Advanced features

Advanced features to develop and maintain
your fault tree diagrams

6.

Customisation

How to change the customisation and print set
up options for fault trees.
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Part B – Event Fault Trees
7.

Logidraw Quick Tour

Tutorial for using Logidraw to draw an event
tree

8.

Event tree basics

shows you how to manage event tree projects.
How to create, change and delete event trees

9.

Advanced features

Advanced features for your event tree
diagrams

10. Customisation

How to change the customisation options for
event trees.

The guide also includes a quick reference and a shortcuts section in each part and a
glossary.

Conventions
The following typographical conventions are used in this guide:
Convention

Description

Bold

To help with procedures, items that you click, select, or view may appear
with the bold format (buttons, options, and window titles, for example).

Italic

Proper names (software products, for example) and titles appear in the
italic format.

Monospace

Represents any text that appears on the computer screen or text that you
should type. It is also used for filenames, functions, and examples.

Monospace
oblique

Represents variable text where you would type in a specific value.

>
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The chevron indicates a menu option in a procedure. For example, click
File > Open, means “on the File menu, click Open.”

Chapter 1 – Introduction
Logidraw lets you create fault tree diagrams and event tree diagrams as part of a
process hazard analysis or safety case for large process plants.

Hazard studies
Large plants in the chemical or process industries need to perform hazard and risk
studies to identify process related hazards and to assess the adequacy of safeguards. A
number of different techniques and methods may be used in these studies, such as:
 Hazard and Operability (HAZOP) study
 Failure Modes and Effects Analysis (FMEA)
 Safety Integrity Level (SIL) Assessment
 Layer of Protection Analysis (LOPA)
 Fault Tree Analysis (FTA) / Event Tree Analysis (ETA)

Process safety
Process safety is a key consideration in the design, building and commissioning of any
chemical or process plant or system. Key questions that need answers are:
 What can go wrong?
 How often will this happen?
 What will be the consequences?
Answering the first question involves some form of hazard identification . Typically
this will involve a formal technique, such as a Hazard and Operability (HAZOP)
study. Providing answers to the other two questions involves using hazard analysis
techniques. This could be a qualitative process, such as Layer of Protection Analysis
(LOPA) or more quantitative techniques, such as Fault Tree Analysis (FTA), Event
Tree Analysis (ETA), or sometimes a combination of the two.

Fault tree analysis
Fault tree analysis involves drawing a logic diagram to show the logical links between
certain failure (basic) events, such as operator error or component failure, and an
undesired outcome (top) event, such as an explosion at an oil storage depot.
The diagram can then be used in two ways:
 qualitatively – to show the combinations of basic events sufficient to cause the
occurrence of the top event,
 quantitatively – to estimate the probability or frequency of an event.
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Logidraw helps you create fault tree diagrams by adding each of the basic failure
events as a series of inputs and then linking them using AND and OR logic gates.
Each input can be quantified typically as a probability or a frequency, with the output
of the final gate providing a frequency for the final (undesired) outcome.

Event tree analysis
Event tree analysis involves tracing the consequences from an undesired initiator
event (such as a compoinent failure) through a series of subsequent events through to a
series of final consequences.

Logidraw helps you create event tree diagrams, with each event added as a success or
failure gate with a split of probabilities of taking either branch. The overall outcome of
a range of "top events" arising from the initial event can then be seen.

Bowtie diagrams
A Bowtie diagram is a graphical representation of the links between the causes of
hazardous events (on the left side of the diagram), an undesired event (such as loss of
containment) and the possible consequences of the undesired event on the right side of
the diagram. Safeguards are shown on both sides of the tie, sometimes considered to
4
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be preventative safeguards on the left and reactive safeguards or mitigations on the
right.
The diagram can be used at different of detail. At a simple level, it can be used
qualitatively to show which safeguards apply to particular causes or consequences.
This is how it may be used in a safety case or process hazard review (PHR). At a more
detailed level, a detailed fault tree on the left and event tree on the right can include
quantitative calculations.

Logidraw allow you to use a bowtie diagram in a quantitative way by connecting the
starting event in the event tree diagram to the final outcome of a fault tree diagram.

Overview of PEL
PEL is a collection of tools to enable process engineers to carry out their day-to-day
tasks more quickly and reliably. The software includes purpose built programs to
generate datasheets, perform engineering calculations of liquid and / or gas flow,
investigate physical properties and create fault tree diagrams. Designed by engineers
for engineers, the tools are intuitive and easy to use. They can be used to work out
every day calculations, for troubleshooting issues such as bottlenecks, or when making
plant modifications. This low cost solution will enable engineers to design processes
more quickly and reliably with up-to-date and permanently available design data.
Benefits
 Allows engineers to be more efficient and productive. With fewer manual
calculations to do, tasks are carried out quicker;
 Improves QA and standardises procedures, through everyone using same set of
data and calculations;
 Human errors in calculations are reduced;
 Improves production as bottlenecks can be identified quickly so a solution can be
sought;
 Allows operators to get the best out of their existing assets by carrying out
modifications rather than designing new ones.
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Chapter 2 – Getting started
This chapter shows you how to start Logidraw and introduces the user interface for the
application.

Starting Logidraw
The most common way of starting Logidraw is from the Windows Start menu, but you
can also run it from a desktop shortcut.
To start Logidraw from the Start menu:
 Click Start > All Programs > PEL > Logidraw.
If using the classic Start menu or earlier versions of Windows, click Start >
Programs...
The Logidraw application opens.

Quitting Logidraw
To quit Logidraw:
 Do one of:
 On the File menu, click Exit.
 Click the Close (X) button.
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User interface
Once you have started Logidraw, you see the following, or similar, user interface.

The following main features are apparent:
Menu bar.

Shows the command menus for accessing various features of the
application. The menu expands to include extra options when a diagram is open.
Main pane.

The main area of the screen where you open your diagrams.

A quick start toolbar appears in the centre.
Status bar. This shows a progress bar during lengthy operations (such as when

calculating sensitive inputs or when the logic diagram is being redrawn).

Project windows
Within the overall main pane your project diagrams appear while open. You can have
multiple projects open concurrently, using the standard Windows commands (tile,
cascade, maximize, etc) to arrange the space. The arrangement of the windows differs
between fault tree diagrams and event tree diagrams.
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Fault tree project window
The layout of a fault tree diagram looks as follows:

The main parts of the fault tree window are:
Project toolbar This contains buttons for the most common commands, such as
Add Input and Connect As Gate.

This shows the value of each input. When a input is added, or
changed, the panel shows the new value. The panel separates frequency inputs from
probability, time and multiplier inputs by using two separate columns. The reference
string is also displayed for each input.
Inputs panel

The main area of the project window shows the logic diagram.
Inputs are drawn from top to bottom: logic is constructed from left to right.
Logic diagram

Commands on the View menu let you show or hide the inputs panel, the project
toolbar and the status bar. You can also define which of these features appear by
default using the Customise options.

Event tree window
An event tree window is a single pane. The status bar is not used with an event tree.
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The main parts of the event tree window are:
Event levels.

Each event level appears as a column.

Results panel. The final outcomes appear as the results panel.
Event lines. Each event line is labelled with the event name, its outcome probability
and the outcome value.
Commands on the View menu let you show (or hide) the outcome probabilities, the
outcome values and the column lines.

Menu bar
The options on the menu bar differ between fault tree diagrams (top) and event tree
diagrams.

The Data and Maths menus only appear for a fault tree diagram: the Connect and Tree
menus are only for event trees. In addition, the Edit and View menus have different
options for each diagram type.

User assistance
Logidraw has the following forms of user assistance:
 Online help
 Online documentation
 PEL Support Services

Online help
Logidraw has an integrated online help system, which provides clear reference
information and step-by-step instructions for tasks. This is an online help version of
this guide.
To open the help system:
 On the Help menu, click User Guide.
The help opens in a separate window.

Online documentation
Documentation is provided for PEL products on the website. The documents are
provided as PDF files for you to download and print. These include:
 60 second guides
 Online user guides
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PEL Support Services
This program is developed, maintained and supported by PEL Support Services, ABB.
We run a Hotline telephone and email service to answer any queries about Logidraw.
Please let us have any suggestions on how you feel we could improve Logidraw. You
can contact us by any of the following routes:
By Telephone:

+44 (0)1925 74 1126

By Fax:

+44 (0)1925 74 1265

By email:

pel.support@gb.abb.com

By Post:

PEL Support Services
ABB Limited.
Daresbury Park
Daresbury
Warrington
Cheshire WA4 4BT
United Kingdom.
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Chapter 3 – Fault trees Quick Tour
This short self-paced tutorial will show you how to begin to draw Fault Trees using
Logidraw.
The diagram below describes the demands and protection failures that, when they
occur, lead to a specific overpressure event.
Within seconds from now you will have learned how to draw this Fault Tree:

Okay start Logidraw.
1)

Click Start > Programs > PEL > Logidraw. After the splash screen disappears,
click Create A Fault Tree and when the Fault Tree Project window appears enter
the title as 60 Second Guide and click OK.
The first thing to do is to display the logic and Project Toolbar

2)

Click the View menu and check Project Toolbar.
We are now ready to create the first two demand Inputs.

3)

Click Add Input on the toolbar to open the “Inputs in Logidraw Fault Tree”
window. Enter Demand 1 in the Comment box, select the type Frequency using
the radio buttons, and enter 0.5 in the Value field which corresponds to a demand
rate of once in 2 years. Click Add to enter this data.
When we clicked Add, Logidraw cleared the data ready for the next Input. So
let‟s add the second demand input.

4)

Enter Demand 2 in the Comment box, select the type Frequency using the radio
buttons, and enter 0.1 in the Value field which corresponds to a demand rate of
once in 10 years. Click Add to enter this data.
The risk from these two sources of demand is reduced by an alarm but what
happens if the operator fails to respond?

5)

Enter Alarm 1 – no operator response in the Comment box, leave the selected
type as Probability, and enter 0.2 in the Value field which corresponds to a
failure probability of 1 in 5. Click Add to enter this data and then click Close to
close the window.
We now have three inputs on the
screen like this:
We now need to draw some gates.
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6)

Select Demand 1 by clicking it, hold down the Ctrl key, and select Demand 2 by
clicking that too. Release the Ctrl key and click Connect as Gate on the toolbar.
When the Gate No 1 window opens, click OK.
We now have the two demands connected into an OR Gate. Let‟s add another
gate to link in the third input.

7)

Click the OR Gate and then the input Alarm 1 – no operator response. Again
click Connect as Gate. When the Gate No 2 window opens, click OK.
This will create another gate, an AND Gate this time. Now we need to create
another demand, Demand 3, a trip input, and a Pressure Relief Valve input.

8)

Click Add Input to open the “Inputs in LogiDraw Fault Tree” window. Enter
Demand 3 in the Comment box, select the type Frequency using the radio
buttons, and enter 0.1 in the Value field which corresponds to a demand rate of
once in 10 years; click Add to enter this data.
Next, enter Trip in failed state in the Comment box, leave the selected type as
Probability, and enter 0.04 in the Value field which corresponds to a failure
probability of 1 in 25; click Add to enter this data.
Finally, enter Pressure Relief Valve in failed state in the Comment box, leave
the selected type as Probability, and enter 0.02 in the Value field to correspond
to a failure probability of 1 in 50; click Add to enter this data and then Close to
close the window.
We need to add three more gates.

9)

Click the AND Gate, then the input Demand 3 and then Connect as Gate on the
toolbar. When the Gate No 3 window appears, click OK. This creates a second
OR Gate.
Now, click this second OR Gate, then the input Trip in failed state, and then
Connect as Gate. When the Gate No 4 window appears, click OK. This creates
a second AND Gate.
Finally, repeat the process for the second AND Gate and the input Pressure
Relief Valve in failed state to create a third AND Gate.
There is a second identical system adjacent to the first that can also fail and cause
the same overpressure event. We can provide for this simply by adding another
input as a multiplier to the final AND gate.

10) Click Add Input to open the “Inputs in Logidraw Fault Tree” window. Enter
Second System Multiplier in the Comment box, select the type Multiplier using
the radio buttons, and enter 2 in the Value field. Click Add to enter this data and
then Close to close the window. Now click this new input and drag the arrow
icon to the final AND gate and drop the icon to connect the input to the gate.
We need to add some gate output descriptions.
11) Double-click the first OR Gate; in the “Detailed Comment” box enter Demand
on Pressure Alarm and click OK. Repeat the above to add the descriptions
detailed on the above diagram for the second OR gate and the last two AND gates
to complete the fault tree.
To complete the exercise, let‟s customise the display to look like the drawing at
the beginning of the guide.
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12) On the File menu, click Customise. When the Customise Options window
appears, click the Display tab and then:
a

Remove the check mark from Display „Short‟ Gate Comment on Screen;

b

Change Max. No. of Characters to Display For Inputs to 40;

c

In the Default Drawing Orientation panel, check Right to Left.

13) Finally click File > Print to print the diagram, which should look like the image
below.
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Chapter 4 – Fault tree basics
The task of creating and maintaining fault trees involves creating a project and then
adding a series of demand inputs and gates to build up the fault tree diagram. This
chapter describes the basics of how to create fault tree projects.

Creating a new fault tree project
The first task in developing a fault tree is to create the project.
To create a new fault tree project:
1)

Do one of:
 On the initial screen click Create A Fault Tree.
 Click File > New > Fault Tree.
 Press Ctrl + N.
The Hazard Under Analysis dialog opens.

2)

Enter a project name for your fault tree and click OK.
A blank fault tree diagram opens in the main pane. You can now start to add
demand inputs and gates to build up the diagram.

Opening an existing fault tree project
To open an existing fault tree project:
1)

Do one of:
 On the initial screen click Load File.
 Click File > Open.
 Press Ctrl + O.

2)

Select Logidraw 95 files (*.LDR) as the file type.

3)

Browse to locate the project file and click Open.
Your fault tree diagram opens in the main pane.
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Opening a legacy fault tree project
Logidraw lets you open fault tree project files created in the earlier DOS version of the
software. These files have a .LOG extension.
To open a legacy fault tree project:
1)

Do one of:
 On the initial screen click Load File.
 Click File > Open.
 Press Ctrl + O.

2)

Select Logidraw DOS files (*.LOG) as the file type.

3)

Browse to locate the project file and click Open.
Your fault tree diagram opens in the main pane.

Defining inputs
Adding inputs
Once you have set up your project file you can start adding demand inputs.
To add an input:
1)

Do one of:
 On the project toolbar click Add Input.
 On the Data menu, click Inputs > Add.
 Right-click in the diagram and click Inputs > Add.
 Press Ctrl+I.
The Inputs in Logidraw Fault Tree dialog opens.
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2)

Specify the input type.

3)

Click Add.

Chapter 4 – Fault tree basics

Editing an existing input
To edit an input:
1)

Do one of:
 Double-click the input in the diagram.
 Right-click the input in the diagram and click Edit Data.
The Inputs in Logidraw Fault Tree dialog opens.

Copying an input
To copy a single input:
 Do one of:
 Select the input in the diagram and then on the project toolbar click Copy
Inputs.
 Right-click the input in the diagram and click Copy.
 Select the input in the diagram and press Ctrl+C and Ctrl+V.
The input is added at the bottom of the diagram.

Deleting an input
To delete a single input:
 Do one of:
 Select the input in the diagram and then on the project toolbar click Delete
Inputs.
 Right-click the input in the diagram and click Delete.
 Select the input in the diagram and press Delete.
To delete multiple inputs:
 Select the inputs in the diagram (Ctrl+click) and then do one of:
 On the project toolbar click Delete Inputs.
 On the Edit menu, click Delete Block.
 Press Delete.
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Connecting inputs with logic gates
Once you have added inputs you need to connect them using logic gates.

Adding a logic gate
To connect inputs with a logic gate:
1)

Select the two inputs you want to connect. Click the first one and then use
Ctrl+click to select the second input.

2)

Do one of:
 On the project toolbar click Connect as Gate.
 On the Data menu, click Connect as Gate.
 Press Ctrl+G.
The Gate dialog opens.

3)

Click OK.

Deleting a gate
This feature lets you delete an individual gate, but leave all the inputs and connections
to its left.
To delete a gate:
1)

Select the gate to be deleted.

2)

Do one of:
 On the project toolbar, Click Delete Gate.
 On the Edit menu, click Delete Gate.
 Right-click the gate and click Delete > Gate.
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Viewing your fault tree diagrams
Logidraw provides various ways in which a logic diagram can be drawn and viewed.
There are two orientation options:
 Left to Right (Align) orientation. Gates within the logic diagram are all aligned
by level. This mode can result in very wide but „neat‟ diagrams.
 Right To Left (Optimise Space) orientation. Gates within the logic diagram
are spaced to accommodate the input/gate/value strings. No aligning takes place.
This mode usually results in „messy‟ looking diagrams, but is efficient in terms of
space.
There is also a Logic Only view. This hides all the gate strings and values. This is
useful if you are editing a very large diagram and space is at a premium.
You can also set a default view using the customisation dialog.
To set the orientation:
 On the View menu click one of:
Orientate Left To Right (Align)
Orientate Right To Left (Optimise Space)

A check mark appears on the menu against the selected option.
To select the logic only view:
 On the View menu click Logic Only.
All gate strings and values are hidden in the diagram. A check mark appears on
the menu against the option.
To clear the logic only view:
 On the View menu click Logic Only again.
Gate strings and values are shown in the diagram. The check mark is removed
from the menu.

Printing your fault tree diagram
To print your fault tree diagram:
1)

Do one of:
 Click File > Print.
 Press Ctrl + P.
The status window opens, showing whether the printout will fit easily on the
page.

23

Logidraw User Guide

2)

If the diagram size is OK, click Proceed.
The diagram is printed on your default printer.

Saving your fault tree project
To save a fault tree project:
1)

Do one of:
 Click File > Save.
 Press Ctrl + S.

2)

Browse to where you want to save the file, enter a file name and click Save.

The project is saved with a file extension .LDR.

Closing a fault tree project
To close the current fault tree project:
 Do one of:
 Click File > Close.
 Click the Close (X) button for the window.
To close all open projects:
 Click File > Close All.
This closes all open fault tree and event tree projects.

24

Chapter 5 – Advanced features
This chapter shows you how to use various advanced features to develop and maintain
your fault tree diagrams.

Sensitivity analysis
Logidraw supports three modes of sensitivity analysis for faults trees – automatic,
spot, and path. The purpose of sensitivity analysis is to determine whether a particular
input or path is critical for the final outcome (end-gate value) of the logic diagram.
For Logidraw to perform any form of sensitivity analysis, an end-gate of non
zero value must exist. If one doesn‟t exist, sensitivity analysis will not proceed.
Note

Automatic sensitivity analysis
If automatic analysis is set on, sensitive paths in the logic diagram are automatically
calculated and updated as you add inputs and logic gates. Automatic analysis works by
halving each input in turn and calculating the percentage change to the end-gate value.
If this change is within a supplied threshold, then the input is regarded as sensitive.
For example, if the threshold is set at 5% then if halving an input‟s value results in a
value +/- 5%, the input is regarded as sensitive.
Sensitive paths can be shown with thicker lines on the display. See Customising Fault
Trees.
To turn automatic sensitivity analysis on (or off):
 On the Maths menu, click Automatic “Real-Time” Sensitivity Calculation.
A check mark appears against the option.

You can set automatic sensitivity analysis on by default using the
Customisation dialog. This also lets you change the sensitivity threshold.
Note

Spot sensitivity analysis
Spot analysis allows you to determine the sensitivity of an input by changing its value
and seeing how the final end-gate value changes.
To spot analyse an input:
1)

Select an input on your diagram and do one of:
 On the Maths menu, click Analyse One Input.
25
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 Right-click and click Analyse.
A dialog opens showing the current details on the input.

2)

Type in a new value for the input and click Analyse.
The analysis routine recalculates the value of the end-gate. If the end-gate value
has changed, an alert appears showing the new value of the end-gate and the
percentage change from the old end-gate value.

3)

Click OK.

Performing path analysis
Paths analysis lets you select a gate and calculate its most sensitive paths
(constituents).
To perform path analysis:
1)

Select a single gate in the diagram and click Maths > Find Most Sensitive Paths
To Gate.
The path analysis routine finds the most sensitive path into that gate. An alert
appears showing the number of sensitive paths found (if any).

2)

Click OK.
If sensitive paths have been found, they appear selected in the diagram. The
routine handles multiple paths having the same sensitivity rating.

To clear the sensitive paths:
 Click Edit > Deselect All.
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Moving entities within a logic diagram
Moving inputs
To move a single input, simply drag the input you wish to move and drop on another
input. the input you have dragged is now positioned above this input.
To move a block of inputs, you must first select the inputs and then drag and drop as
above.

Moving blocks
To move a complete block (i.e., inputs and gates) within the logic diagram you must
drag the gate (which will mark the block you wish to move) to a different location in
the tree. This location must be another logic gate (the „target gate‟).
When a gate is dropped onto another gate the „Block Move‟ dialog appears:

Moving entities using cut & paste
You can move entities using a cut & paste operation. This also lets you move entities
between projects.

Copying entities
Copying inputs
You can copy inputs by selecting the one or more inputs and then pressing Ctrl+C.
This places the selected inputs in the copy buffer. It is then possible to copy these
inputs either above another input or to the end of the input list.
To copy the selected inputs above another input, select another input as a „paste point‟
and then press Ctrl+V to paste the inputs.
To copy the inputs to the end of the inputs list simply press Ctrl+V (with no input
selected).

Copying gate blocks
You can copy Gate blocks in a similar fashion as inputs. However, you can only copy
a single block.
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To copy a gate block, select a gate and then press Ctrl+C. This places the selected gate
block into the copy buffer. It is then possible to copy this gate block into another gate
or to the end of the logic diagram.
To copy the gate block into another gate, select another gate as a „paste point‟ and
then press Ctrl+V to paste the gate. Upon doing this, a block move dialog will request
information as to how the copied gate should be connected into the target gate.
To copy the gate block to the end of the diagram, either:
 Use Ctrl+V with no „paste point‟ selected, OR
 Drag the gate you wish to copy into free space.

Copying entities between projects

Erasing gates and inputs
Two commands let you remove either all the gates in a diagram or all inputs and gates.

Erasing all gates
This command lets you remove all the gates, but leaving all the inputs alone.
To erase all gates:
1)

Click Edit > Erase > Gates only.
A message asks you to confirm that you want to continue.

2)

Click Yes.

Note

You can use the Undo command to recover.

Erasing inputs and gates
This command clears your diagram to start again.
To erase inputs and gates:
1)

Click Edit > Erase > Inputs & Gates .
A message asks you to confirm that you want to continue.

2)

Click Yes.

Note
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Working with connections
Connections on your fault tree diagram are the lines that link an input and a gate.
These commands allow you to develop your diagram by connecting or disconnecting
blocks of inputs and gates within the diagram.

Adding a connection
To add a connection between an input and a gate, the elements to be connected must
be in a position to be connected. For example, in the diagram below we want to
connect the new input (Demand 5) to the selected OR gate. To do this we must drag
(move) the input above demand 3.

The diagram will look as follows:

We can then connect the two.
To connect an input and gate:
1)

Select the two elements to be connected.

2)

Click Data > Connection > Add.

Removing a connection
This lets you remove a connection between any two points.
To remove a connection:
1)

Select the two elements to be disconnected.

2)

Click Data > Connection > Remove.

Unlinking a connection
Sometimes after removing a connection, you may end up with a gate containing only
one input. This feature lets you remove this gate and connect the single input through
to the output of that gate. For example, in the diagram below removing the connection
from demand 7 leaves an orphan gate (in red) with a single input.
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To remove the orphan gate:
1)

Select the orphan gate.

2)

Click Data > Connection > Unlink from Gate.
A message asks if you want to remove the gate and create a through connection.

3)

Click Yes.
The orphan gate is removed.

Advanced editing features
Editing multiple input/gate values
If you need to make changes to a large project with many inputs and gates, you can
search for the items to change by scrolling through a tabular display that shows all the
data in your fault tree.

If sensitivity analysis is on, values marked with an asterisk (*)denote a sensitive path.
To edit mltiple inputs and gates:
1)

Click Edit > Input/Gate Values.
The Input & Gate Values dialog opens.

2)

Scroll down the list and do one of:
 Double-click the input or gate you want to change.
 Select the input or gate to change and click Edit.
The Input or gate dialog opens as appropriate.

3)

Edit the input or gate as required and click OK.
The tree values are automatically recalculated in the dialog. If sensitivity analysis
is on, then sensitivity is also recalculated.

4)
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Repeat as necessary to change all the data you want; then click Close.
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The tree is redrawn to show all your changes.

Inserting a gate
This feature lets you insert a gate between the output of a selected gate and the input
of the gate it feeds. The new gate has the output of the selected gate as one input and a
selected, unconnected input as its second input.
For example, in the diagram below, we want to insert a gate between the output of the
selected AND gate and the OR gate it feeds. The unnconnected input (demand 4) will
provide the second input to the new gate.

With the gate added the diagram will look as follows:

To inset the new gate:
1)

Select the gate after which the new gate is to be inserted, and select the
unconnected input as the other input for the new gate.

2)

Click Data > Insert Gate.
The gate dialog opens.

3)

Enter any comments and then click OK.
The gate is added, connecting the two selected items.

Replacing an input with a gate output
This feature lets you add a series of logic inputs and gates Suppose a user has a logic
diagram where one of the inputs really requires some logic to define it. The user can
develop the defining logic, select the end gate of this logic, select also the input which
it defines, and then replace the input with the logic.
For example, in the diagram below we want to add the selected block at the bottom of
the diagram as the input to demand 4.
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With the input replaced the diagram will look as follows:

To replace the input with a gate output:
1)

Select the end gate of the defining logic and the input it replaces

2)

Click Data > Replace Input with Gate Output.
This will move the defining logic into the part of the logic diagram previously
occupied by the selected input.

Maintaining project details
The Project Details dialog let you maintain various titles and descriptions for your
project, either to annotate the printed view or to be held as background notes.

To change the project details and notes:
1)

Click File > Edit Title & Notes.
The Project Details dialog opens.

2)

Enter or change the following details as required:
Title. The title for the logic diagram.
Date. The date for the logic diagram.
Reference. Reference text.
Page Heading.
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Heading text to appear at the top of first printed page.
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Top Of Diagram Note. Text to appear at the top of the diagram.
Bottom Of Diagram Note. Text to appear at the bottom of the diagram.
Additional Comments To Appear In Notes File. These comments will be
saved in the diagram‟s accompanying notes file.
3)

Click OK.

Maintaining diagram notes
When you save a Logidraw project file, an accompanying text file is automatically
created containing all inputs and reference text (if this option is switched on – see
Specifying input references). The text file also contains additional notes which can be
entered by selecting File/Edit Project Details.
The file created has the same filename as the project but with the extension.TXT. If
the file currently exists, it will be overwritten without warning.
To create or (or regenerate) the notes file:
 Click File > Re-Generate Notes File.
Important Note

If you modify the text file (externally from Logidraw) the changes will be lost when
the project file is re-loaded. This is because the reference details are stored with the
project file and not the text file. The text file is simply a one way „dump‟ of reference
text associated with the project file.

Entering reference text for inputs
Logidraw lets you add reference text when you add or edit an input.
To add reference text for an input:
1)

Do one of:
 Double-click the input in the diagram.
 Right-click the input in the diagram and click Edit Data.
The Inputs in Logidraw Fault Tree dialog opens.

2)

On the Add Input dialog, click Notes.

3)

Enter or change the text as required.
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4)

Click OK to close the dialog.

5)

Click OK again to close the Inputs dialog

Automatic input references
Logidraw assigns reference strings for inputs as they are are created. You can let these
be assigned automatically, specifying a start number and optional prefix/suffix strings.
See Specifying input references.

Re-Generating/Clearing input references
To re-generate input references:
 Do one of:
 Click Data > Inputs > Re-Generate Input References.
 Press Ctrl+K.
The references for each input in the Inputs Panel are refreshed.

To clear all input references
 Click Data > Inputs > Clear References.
Note
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The reference text is not affected.

Chapter 6 – Customising fault trees
Logidraw lets you customise the application via a multi-tab customisation dialog. The
customisation settings are saved in your setup file and are restored each time you start
the application. You can also set options to customise your printouts.
This chapter describes how you can change the customisation and print set up options.

Customisation options for fault trees
The customisation options for fault trees are available when a fault tree project is open
(and on focus) or when you start the application and no project files are open.

Setting a default folder
You can set a default folder for saving and loading your files.
To specify where to look for and save files:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Files tab.

3)

Select the drive and then the folder for your files.

4)

Click OK to save your setting.

Setting display preferences
You can set various options about how your fault trees appear on display. This does
not affect the printed output.
To change the display preferences:
1)

With a fault tree project in focus, click File > Customise.
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2)

Click the Display tab.

3)

Set the following options as required:
Show Sensitive Inputs With Bold Lines. If you select this check box, and
sensitivity analysis is switched on, all sensitive paths will be drawn with thick
connecting lines.
Indent Non-Frequency Inputs. If you select this check box, non frequency
inputs are indented on your diagram. This can improve the readability.
Display Short Comment On Screen. If you select this check box, the short
comment for gates appears on the diagram instead of the full comment. If you
clear the check box, you can enter specify a maximum number of characters to
show for gate strings.
Max No. Of Characters To Display For Inputs. This lets you supply a
maximum number of characters to display for inputs.

4)

Click OK to save your settings.

Using colour on your diagrams
By default Logidraw displays paths on your diagram in colour, with different colours
set for each input type.
To switch off colour:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Display tab.

3)

Clear the Use Colour check box and then click OK to save your setting.

To revert to the default colours:
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1)

With a fault tree project in focus, click File > Customise.

2)

Click the Display tab.

3)

Click Use Defaults to revert to the default colours.

4)

Click OK to save your settings.
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This also returns all other options to the default setting so you will need to
redo other custom settings on the tab.
Note

To specify custom colours:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Display tab.
The colour panel defines a colour for each of input type (probability, frequency,
time and multiplier) and a background colour for the drawing window.

3)

To change a colour, click the button to open the standard Windows colour picker.
Select one of the basic colours, or click Define Custom Colors to select from the
full color palette.

4)

Select your colour and click OK to return to the Display tab.

5)

Click OK again to save your settings.

Setting the default drawing view modes
Logidraw lets you set defaults for the modes that define how a logic diagram is drawn
and viewed. There are two orientation options and a separate logic only view.
To set the default drawing orientation:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Display tab.

3)

Set the default drawing orientation as either of the options:
Left to Right (Align)
Right to Left (Optimise Space

4)

Click OK to save your settings.

To set (clear) the logic only option:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Display tab.

3)

Select (or clear) the Display Logic Only check box.

4)

Click OK to save your settings.
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Setting general display preferences
You can define which parts of the project window appear by default when you load
your files.
To specify general display preferences:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the General tab.

3)

Select (or clear) the check boxes to define which parts of the project window are
open by default.

4)

Click OK to save your settings.

Specifying input references
When you install Logidraw, the default identification for input references is a numeric
sequence starting at one. You can start the sequence at a different value and add a
prefix and/or suffix to allow unique identification over multiple projects.
To specify input references:
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1)

With a fault tree project in focus, click File > Customise.

2)

Click the Input References tab.

3)

Enter a prefix and/or suffix as required.
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4)

Enter a new start number if you want to continue from another project.

5)

Click OK to save your settings.

To clear automatic numbering of inputs:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Input References tab.

3)

Clear the Automatically Generate Sequential Input References check box.

4)

Click OK to save your settings.

The reference field will now be blank when you add inputs to your fault tree.
To stop (or start) automatic creation of a comments text file:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Input References tab.

3)

Clear (or select) the Create Comments File When Project is Saved check box.

4)

Click OK to save your settings.

If the check box is selected a text file containing all your inputs and reference text is
created when you save your project file.

Building a glossary
The Glossary tab lets you build up a selection of phrases to be saved in your user
setup file. You can recall these phrases in any project dialog by pressing Ctrl+W.
Recalling phrases can be useful when entering gate comments/input descriptions.

To open the glossary:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Glossary tab.
You can add, change or remove phrases from the glossary.

To add a phrase to the glossary:
1)

Type your phrase in the Phrase text box and click Add.
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The phrase is added to the Saved Phrases list.
2)

Repeat as necessary to add more phrases.

3)

Click OK to save the glossary.

To replace a phrase in the glossary:
1)

Select a phrase in the the Saved Phrases list.

2)

In the Phrase text box, edit the phrase as you want and then click Replace.
The edited phrase replaces the original in the Saved Phrases list.

3)

Click OK to save the glossary.

To remove a phrase from the glossary:
1)

Select a phrase in the the Saved Phrases list and then click Remove.
The phrase is removed from the Saved Phrases list.

2)

Click OK to save the glossary (and make the deletion permanent).

Setting sensitivity analysis preferences
The Maths tab lets you set automatic sensitivity analysis on by default. You can also
change the sensitivity threshold for inputs.
To specify sensitivity analysis preferences:
1)

With a fault tree project in focus, click File > Customise.

2)

Click the Maths tab.

3)

Select the check box to set automatic sensitivity analysis on by default.
Clear the check box to set automatic sensitivity analysis off.
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4)

The sensitivity is set to 5% when you install Logidraw. Enter a new value if
required.

5)

Click OK to save your settings.
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Printing setup
The print setup dialog lets you set various options used when printing your fault tree
(or event tree) diagram.
Note

Some of the options only apply to fault trees.

To set the printing options for your diagram:
1)

Click File > Print Setup.

2)

Under Margins, adjust the page margins (in centimetres) as required.

3)

Click OK to save the changes.

Setting the resizing options for fault trees
These options control how fault tree diagram are resized for printing.
To set the resizing options:
1)

Click File > Print Setup.

2)

If you select the Automatically Attempt Folding check box, Logidraw will wrap
long text strings on inputs and comments to help make the printout fit.

3)

For font reduction, select the Automatically Reduce Font check box and then set
the starting and minimum font sizes. A Starting Font Size of 12 and a Minimim
Font Size of 6 are typical values.

4)

Click OK to save the changes.

Setting the Confidentiality text
This lets you customise the text that appears at the top of each printed sheet.
To set the confidentiality text:
1)

Click File > Print Setup.
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2)

Enter the new text as required.

3)

Click OK to save the changes.

Resetting all the print options
To reset all the print options:
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1)

Click File > Print Setup.

2)

Click Use Defaults.

3)

Click OK to save the changes.

Quick reference
The following tables define the commands on the menu system.

File menu
Command

Action

See

New > Fault Tree

Create a new fault tree project

“Creating a new fault tree
project” on page 19

New > Event Tree

Create a new event tree project

“Creating a new event tree
project” on page 55

Open

Open a Logidraw file (.evt, .ldr, .log)

“Opening an existing fault
tree project” on page 19

Close

Close the current file (prompting
user to save file)

“Closing a fault tree
project” on page 24

Close All

Close the all open files (prompting
user to save each currently open
file)

“Closing a fault tree
project” on page 24

Save

Save the current file with current
filename (for new Projects this gives
Save As dialog) - during Saving both
*.Ldr and *.Txt files are saved

“Saving your fault tree
project” on page 24

Save As

Save the files with new names;
creates file name for new Projects

Edit Title & Notes

Edit the Project details recorded in
Logidraw files

“Maintaining project
details” on page 32

Re-generate Notes
File

Re-save the *.Txt file

“Maintaining diagram
notes” on page 33

Print Setup

Set the Printing Options

“Printing setup” on page 41

Print

Print the Logic Diagram

“Printing your fault tree
diagram” on page 23

Customise

Set the user Preferences

“Customisation options for
fault trees” on page 35

Exit

Quit Logidraw

“Quitting Logidraw” on
page 7
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Edit menu
These options only appear when a fault tree is open.
Command

Action

See

Input/Gate Values

Open a window listing all inputs and
gates which can then be selected
and edited

“Editing multiple input/gate
values” on page 30

Undo

Undo the last change

Redo

Redo the last change

Copy Diagram To
Clipboard

Copy a printout of the diagram to the
clipboard

Cut

Cut selected item to the clipboard

Copy

Copy selected item to the clipboard

Paste

Copy selected item from the
clipboard

Delete Block

Delete the selected gate and delete
all the logic leading to the inputs of
the gate

“Deleting an input” on page
21

Delete Gate

Delete a selected gate but leave the
logic leading to all the inputs of the
gate

“Deleting a gate” on page
22

Erase > Gates only

Erase all gates in the diagram

“Erasing all gates” on page
28

Erase > Inputs &
Gates

Erase the complete diagram

“Erasing inputs and gates”
on page 28

Deselect All

Deselect all selected inputs and
gates

View menu
These options only appear when a fault tree is open.
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Command

Action

See

Redraw

Redraws the screen

Logic Only

Selects display of Logic without gate
comments and numeric values

“Viewing your fault tree
diagrams” on page 23

Orientate Left to
Right (Align)

Selects on-screen vertical alignment
of gates according to hierarchical
level in the logic

“Viewing your fault tree
diagrams” on page 23

Orientate Right to
Left (Optimise space)

Gates moved as close to inputs as
permitted to Optimise space.

“Viewing your fault tree
diagrams” on page 23

Project Toolbar

Show/hide the project toolbar

“Viewing your fault tree
diagrams” on page 23

Status Bar

Show/hide the status bar

“Fault tree project window”
on page 9

Inputs Panel

Show/hide the inputs panel

“Fault tree project window”
on page 9

Quick reference

Data menu
This menu only appears when a fault tree is open.
Command

Action

See

Inputs > Add

Add input

“Adding inputs” on page 20

Inputs > Re-Generate
Input References

Regenerate input references

“Re-Generating/Clearing
input references” on page
34

Inputs > Clear
References

Clear input references

“Re-Generating/Clearing
input references” on page
34

Connect as Gate

Connects selected inputs and gate
outputs as inputs to a new gate

“Adding a logic gate” on
page 22

Connection > Add

Add connection

“Adding a connection” on
page 29

Connection >
Remove

Remove connection

“Removing a connection”
on page 29

Connection > Unlink
Gate

Unlink gate

“Unlinking a connection”
on page 29

Insert Gate

Insert a new gate

“Inserting a gate” on page
31

Replace Input With
Gate Output

Replace input with block of logic

“Replacing an input with a
gate output” on page 31

Maths menu
This menu only appears when a fault tree is open.
Command

Action

See

Analyse One Input

Enables the effect of a change to the
value of a selected input to be
calculated in terms of its % change
on the value of the final gate output
value.

“Spot sensitivity analysis”
on page 25

Find Most Sensitive
Path(s) To Gate

Highlights the sensitive paths to a
selected gate.

“Performing path analysis”
on page 26

Automatic “RealTime” Sensitivity
Calculation

Selects automatic sensitivity
assessment of inputs and indication
by line thickness

“Automatic sensitivity
analysis” on page 25

Command

Action

See

Tile Horizontally

Tile open diagrams side-by-side

Window menu

Tile Vertically
Cascade

Overlay open diagrams

Arrange Icons

Arrange minimised diagram icons
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Help menu
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Command

Action

Help – User Guide

Open the online help version of the
Logidraw User Guide

Check for updates

Check if you have the latest version
of the software

About

Open the Logidraw splash screen

See

Shortcuts
The following table shows the keyboard shortcuts that let you perform commands
quickly.
Command

Action

Menu equivalent

Ctrl+N

New Fault Tree

File > New > Fault Tree

Ctrl+O

Open

File > Open

Ctrl+S

Save

File > Save

Ctrl+A

Save All

File > Save All

Ctrl+P

Print

File > Print

F12

Open Customisation Options

File > Customise

Fault trees
These shortcuts are only available when a fault tree is open.
Command

Action

Menu equivalent

Ctrl+Z

Undo the last change

Edit > Undo

Ctrl+Y

Redo the last change

Edit > Redo

Ctrl+X

Cut

Edit > Cut

Ctrl+C

Copy

Edit > Copy

Ctrl+V

Paste

Edit > Paste

Del

Delete Block

Edit > Delete Block

Ctrl+R

Redraw

View > Redraw

Ctrl +I

Add input

Data > Inputs > Add

Ctrl +K

Regenerate input references

Data > Inputs >
Regenerate Input
References

Ctrl +G

Connect inputs as a gate

Data > Connect as Gate

PgUp,PgDn

Scroll diagram up or down

Ctrl+PgUp,PgDn

Scroll diagram to top or bottom

Ctrl+Home,End

Scroll diagram to top or bottom

Left,right arrow keys

Scroll diagram left or right

Ctrl+left/right arrow

Scroll to left or right margin
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Chapter 7 – Event trees Quick Tour
This short self-paced tutorial will show you how to begin to draw Event Trees using
Logidraw.
We describe the events and the outcomes that occur when a level control fails. There
are two event levels – one for the hardware and one for the operator - with one event
in each level each of which has two outcomes.
Within seconds from now you will have learned how to draw the Event Tree below:

Okay start Logidraw.
Starting Logidraw
1)

Click Start > Programs > PEL > Logidraw. After the splash screen disappears,
click Create Event Tree and when the Event Tree Project window appears enter
the title as 60 Second Guide and click OK.
The first thing to do is to create the Initiator Event.

2)

Click the window to add the Initiator Event and then enter the event name as
Failure of Level Control.
Next we need to specify outcomes. By default each new event has 2 outcomes
named S (success) and F (failure) each with a probability of 50%. We need to
rename the outcomes and specify new probabilities.

3)

Double-click S(0.5) in the Outcome list and rename the outcome to High Level
Alarm operates. Set the probability as 0.9 and click OK. Repeat for outcome
F(0.5) renaming it to High Level Alarm in failed state with a probability of 0.1
and click OK.
To complete the input for the Initiator Event we need to specify a frequency of
0.1 per year.

4)

Keeping the Input Value Type as Frequency, type 0.1 into Value and select yr in
the Units list. Finally click OK.
Now we need to give this level of the event tree a meaningful name.

5)

Double-click the heading Level 1 and rename it to Alarm Hardware.
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We now have the Initiator Event with the first event level. Next we need to add
the second level of events.
6)

Click the first outcome. The event and its outcomes are highlighted blue and the
selected outcome also has blue handles on it. Right-click this outcome (the blue
horizontal line - not the handles) and click the last item Attach Event to
Outcome.
This will create two further outcomes that we again need to rename and reset
their probabilities.

7)

Edit the outcome S(0.5) and rename it to Operator stops flow to tank; set the
probability to 0.8. Repeat for outcome F(0.5) renaming it to Flow to tank not
stopped by operator with a probability of 0.2.
Now we need to promote the second outcome of the event in the first level to the
final outcome column.

8)

Click the second outcome in the Alarm Hardware column to give it blue handles
then right- click and click Promote to Outcome Column. This will extend the
outcome to the final Outcomes column.
Complete this second level of events by renaming the header.

9)

Double-click the heading Level 2 and rename it to Operator response to Alarm.
Finally we need to add the final outcome descriptions.

10) Double-click 0.072 in the Outcomes Value column and add the description No
Overflow and click OK. Repeat for the values 0.018, 0.010 and enter Overflow
Occurs for each description.
We should now have a total frequency that overflow occurs of 0.028/yr.
And that‟s it! If you have time try extending the drawing to include a third event
level called Trip Function as shown below:

11) First attach a new event to the outcome Flow to tank not stopped by operator
with two new outcomes (a) Trip in working state stops flow with a probability
of 0.95 and (b) Trip in failed state with a probability of 0.05.
12) Next, attach a new event to the outcome High Level Alarm in failed state again
with two outcomes (a) Trip in working state stops flow with a probability of
0.95 and (b) Trip in failed state with a probability of 0.05.
13) Next, promote the outcome Operator stops flow to tank to the final Outcomes
column.
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14) Complete the drawing by renaming the Level 3 header to Trip Function and
adding appropriate descriptions to the final Outcomes.
15) Finally, on the File menu click Customise and set the font size to 10 pt for the
column headings and to 8 pt regular for the Outcome text and values.
You should end up with a total frequency that overflow occurs of 0.001/yr.
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Chapter 8 – Event trees basics
The task of creating and maintaining event trees involves creating a project and then
adding a series of events and outcomes to build up the event tree diagram. This
chapter shows you how to manage event tree projects.

Creating a new event tree project
The first task in developing an event tree is to create the project.
To create a new event tree project:
1)

Do one of:
 On the initial screen click Create Event Tree.
 Click File > New > Event Tree.
 Press Ctrl + E.
The Event Tree dialog opens.

2)

Enter a project name for your event tree and click OK.
A blank event tree diagram opens in the main pane.

You can now start to add events and outcomes to build up the diagram.

Opening an existing event tree project
To open an existing event tree project:
1)

Do one of:
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 On the initial screen click Load File.
 Click File > Open.
 Press Ctrl + O.
 Select Logidraw Event Diagrams (*.EVT) as the file type.
2)

Browse to locate the project file and click Open.
Your event tree diagram opens in the main pane.

Adding events
Adding the initiator event
Once you have set up your project file you can start adding events.
To add the initiator event:
1)

Click the background of the project window you have just created.
The Create initiator event dialog opens.

2)

Enter the name or short description for the event.

3)

Change the outcomes as required.

4)
5)

Click OK.

Adding null events
You can add levels to your chart by adding Null events.
Inserting a null event adds the event to the left of the current level and moves the
following levels to the right. Appending a null event adds the event to the right of the
current level.
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Inserting a null event to the left
To insert a null event:
 Select the level where you want the null evnt to be added and do one of:
 On the Tree menu click Insert NULL Event.
 Right-click and click Insert NULL Event.

Appending a null event
To append a null event:
 Do one of:
 Select the null event in the diagram and then on the Tree menu click
Append NULL Event.
 Right-click the null event in the diagram and click Append NULL Event.

Deleting a null event
To delete a null event:
1)

Do one of:
 Select the null event in the diagram and then on the Tree menu click Delete
NULL Event.
 Right-click the null event in the diagram and click Delete NULL Event.
A prompt asks you if you want to delete the event.

2)

Click Yes.
The Null event is deleted and following event levels are moved to the left.

Editing events
Entering reference text for events and outcomes
Logidraw lets you add reference text when you edit an event or outcome.
To add reference text for the initiator event:
1)

Do one of:
 Double-click the initiator event in the diagram.
 Right-click the initiator event and click Edit Event.
 Select the initiator event and on the Tree menu click Edit Event.
The Edit Initiator Event dialog opens.

2)

On the dialog, click Notes.
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3)

Enter or change the text as required

4)

Click OK to close the dialog.

5)

Click OK again to close the Edit Initiator Event dialog.

To add reference text for an outcome:
1)

Do one of:
 Double-click the outcome in the diagram.
 Right-click the outcome and click Edit Outcome.
 Select the outcome, and on the Tree menu click Edit Outcome.
The Edit Outcome dialog opens.

2)

On the dialog, click Notes.

3)

Enter or change the text as required

4)

Click OK to close the dialog.

5)

Click OK again to close the Edit Outcome dialog.

Viewing your event tree diagrams
Logidraw provides various ways in which an event diagram can be drawn and viewed.
There are two options:
 Fitted. The event tree is compressed to fit the window.
 Scrolled. The event tree is allowed to scroll without any compression.
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To set the view:
 On the View menu click one of:
Fitted
Scrolled

A check mark appears on the menu against the selected option.

Printing your event tree diagram
To print your event tree diagram:
1)

Do one of:
 Click File > Print.
 Press Ctrl + P.
The diagram is printed on your default printer.

Saving your event tree project
To save an event tree project:
1)

Do one of:
 Click File > Save.
 Press Ctrl + S.

2)

Browse to where you want to save the file, enter a file name and click Save.

The project is saved with a file extension .EVT.

Closing an event tree project
To close the current event tree project:
 Do one of:
 Click File > Close.
 Click the Close (X) button for the window.
To close all open projects:
 Click File > Close All.
This closes all open fault tree and event tree projects.
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Chapter 9 – Advanced features
This chapter shows you how to use various advanced features for your event tree
diagrams.

Erasing all events
This command clears your diagram to start again.
To erase all events:
1)

Click Edit > Erase All Events .
A message asks you to confirm that you want to continue.

2)

Click Yes.

Note

You cannot undo this command .

Connecting a fault tree to an event tree
Logidraw lets you connect the final gate from a fault tree as the input to an event tree.
The final gate value must be a frequency or probability.
To connect a fault tree:
3)

Open the Fault tree project whose output you want to use.

4)

Switch the focus to your Event tree diagram.

5)

On the Connect menu, click Connect Fault Tree Output.
The Connect From Fault Tree Gate dialog opens.

6)

Select the output gate and click OK.
Details on the connection appear in the top banner (in blue) and the gate value is
shown on the selected initator event.
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To disconnect a fault tree:
1)

On the Connect menu, click Disconnect Fault Tree Output.
A message tells you the Fault tree has been disconnected.

2)

Click OK.
The top banner is cleared but the gate value remains for the initator event.
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Chapter 10 – Customising event trees
Logidraw lets you customise the application via a multi-tab customisation dialog. The
customisation settings are saved in your setup file and are restored each time you start
the application.
This chapter describes how you can change the following aspects of how Logidraw
works:

Customisation options for event trees
The options for event trees define the various fonts used in drawing the diagram and
the line style.

The customisation options for event trees are available when an event tree project is
open (and on focus) or when you start the application and no project files are open.
To specify event tree preferences:
1)

With an event tree project in focus, click File > Customise.
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The dialog defines a font for each of: column headings, outcome text, outcome
values and results panel.
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2)

To change a font, click the Change to open the standard Windows font picker.

3)

Select your font, style and size and click OK to return to the Customisation
Options dialog.

Quick reference
The following tables define the commands on the menu system.

File menu
Command

Action

See

New > Fault Tree

Create a new fault tree project

“Creating a new fault tree
project” on page 19

New > Event Tree

Create a new event tree project

“Creating a new event tree
project” on page 55

Open

Open a Logidraw file (.evt, .ldr, .log)

“Opening an existing fault
tree project” on page 19

Close

Close the current file (prompting
user to save file)

“Closing a fault tree
project” on page 24

Close All

Close the all open files (prompting
user to save each currently open
file)

“Closing a fault tree
project” on page 24

Save

Save the current file with current
filename (for new Projects this gives
Save As dialog) - during Saving both
*.Ldr and *.Txt files are saved

“Saving your fault tree
project” on page 24

Save As

Save the files with new names;
creates file name for new Projects

Edit Title & Notes

Edit the Project details recorded in
Logidraw files

“Maintaining project
details” on page 32

Re-generate Notes
File

Re-save the *.Txt file

“Maintaining diagram
notes” on page 33

Print Setup

Set the Printing Options

Print

Print the Logic Diagram

“Printing your event tree
diagram” on page 59

Customise

Set the user Preferences

“Customisation options for
event trees” on page 63

Exit

Quit Logidraw

“Quitting Logidraw” on
page 7
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Edit menu
These options only appear when an event tree is open.
Command

Action

Undo

Undo for last change

Redo

Redo the last change

Erase All Events

Erase the complete diagram

Copy Diagram To
Clipboard

Copy the diagram to the clipboard

See

“Erasing all events” on
page 61

View menu
These options only appear when an event tree is open.
Command

Action

See

Fitted

Fit the event tree to the window

“Viewing your event tree
diagrams” on page 58

Scrolled

Let the event tree scroll to view

“Viewing your event tree
diagrams” on page 58

Show Outcome
Probabilities

Show/hide the outcome probabilities

“Event tree window” on
page 9

Show Outcome
Values

Show/hide the outcome values

“Event tree window” on
page 9

Show Column Lines

Show/hide the column lines

“Event tree window” on
page 9

Connect menu
This menu only appears when an event tree is open.
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Command

Action

See

Connect Fault Tree
Output

Connect a fault tree output to an
event tree

“Connecting a fault tree to
an event tree” on page 61

Disconnect Fault
Tree Output

Disconnect fault tree from an event
tree

“Connecting a fault tree to
an event tree” on page 61

Quick reference

Tree menu
This menu only appears when an event tree is open.
Command

Action

See

Insert Null Event to
Left

Insert a null event to the left

“Inserting a null event to
the left” on page 57

Append NULL Event

Append a null event

“Appending a null event”
on page 57

Command

Action

See

Tile Horizontally

Tile open diagrams side-by-side

Promote to Outcome
Column

Edit Event
Delete Event
Add Outcome
Delete Outcome
Edit Outcome
Attach Event to
Outcome

Window menu

Tile Vertically
Cascade

Overlay open diagrams

Arrange Icons

Arrange minimised diagram icons

Help menu
Command

Action

Help – User Guide

Open the online help version of the
Logidraw User Guide

Check for updates

Check if you have the latest version
of the software

About

Open the Logidraw splash screen

See
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Shortcuts
The following table shows the keyboard shortcuts that let you perform commands
quickly.
Command

Action

Menu equivalent

Ctrl+E

New Event Tree

File > New > Event Tree

Ctrl+O

Open

File > Open

Ctrl+S

Save

File > Save

Ctrl+A

Save All

File > Save All

Ctrl+P

Print

File > Print

F12

Open Customisation Options

File > Customise

Event trees
These shortcuts are only available when an event tree is open.
Command

Action

Menu equivalent

Ctrl+Z

Undo the last change

Edit > Undo

Ctrl+Y

Redo the last change

Edit > Redo
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Revision history
The following table records the revision history of this guide.
Revision

Date

Description of change

1.0

10 Oct 2002

First Approved Issue

1.1

24 Oct 2005

Removed Industrial IT logo

2.0

4 Feb 2013

Completely rewritten to include Event trees and Undo/Redo
changes
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Glossary
AND Special Gates
This gate type is generally used when we wish to combine multiple frequencies into an
AND gate and supply an off-line calculation. An output dimension must be supplied
for a gate of this type.

Constituent
A constituent is simply an input to a gate. This input can be a primary input or a gate
output.

End-Gate
An end-gate is simply the final gate of a logic diagram. A valid logic diagram can
have only one end-gate. The edit gate dialog displays „(End-Gate)‟ in the caption of
the dialog if a gate is an end-gate.

Entity
In Logidraw, an entity is simply an input or a gate.

ETA
Event Tree Analysis

FMEA
Failure Modes and Effects Analysis. A technique for failure analysis developed in the
1950s for analysing component failures in military system and their causes and
effects. It is essentially a qualitative analysis.

FTA
Fault Tree Analysis

HAZOP
Hazards and operability study. A process hazards analysis procedure originally
developed by ICI in the 1970s. The method is highly structured and divides the
process into different operationally-based nodes and investigates the behaviour of the
different parts of each node based on an array of possible deviation conditions or
guidewords.
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LOPA
Layer of Protection Analysis. A method of analysing the likelihood (frequency) of a
harmful outcome event based on an initiating event frequency and on the probability
of failure of a series of independent layers of protection capable of preventing the
harmful outcome.

MDI
Multiple Document Interface.

PHR
Process Hazard Review

QRA
Quantitative risk assessment.

SIL
Safety Integrity Level. A quantitative target for measuring the level of performance
needed for safety function to achieve a tolerable risk for a process hazard.
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T
Tree menu 67

U
Unlinking a connection 29
Using colour on your diagrams 36

V
View menu 44, 66

W
Window menu 45, 67
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